Issue
In some environments, clicking the "Activate" button on the xDM Native App UI does nothing:
- No visible progress.
- No error message in the UI.
- No obvious indication that the activation workflow was triggered.
Cause
Clicking the button "Activate" should trigger the activation workflow (service creation, container provisioning, endpoint creation, etc.) and eventually expose the xDM server URL.
Behind this action, SQL calls are made to our stored procedures.
So, when the activation silently fails, it is difficult to:
- Confirm that the application is correctly installed.
- Check that services exist and are in the right state.
- Manually trigger / verify startup.
- Retrieve the xDM instance URL.
Solution
- Login to the Snowflake environment.
- Ensure the warehouse is running.
- In the SQL queries on the workspace, ensure the database is selected at the top.
- Identify your application:
SHOW APPLICATIONS;
- Check your Snowflake Native App details:
DESCRIBE APPLICATION <your_app>;
- Declare and check your setup token:
SEMARCHY_SETUP_TOKEN='<your_secret_value>'; select $SEMARCHY_SETUP_TOKEN;
- Start the Semarchy Native App:
CALL <native_app_name>.xdm_public.start_app($SEMARCHY_SETUP_TOKEN);
- Verify your installation by checking the service status:
CALL <native_app_name>.xdm_public.service_status();
- Retrieve your xDM server URL:
CALL <native_app_name>.xdm_public.xdm_server_url();