Issue

When trying to log in Semarchy xDM, a user may encounter a "Too many failed login attempts" message, preventing access to the system.


Cause

This message is triggered when the number of failed login attempts from an IP address exceeds the limit (the default is 5 attempts), thereby locking access from that address for 24 hours.


Solution

1- To resolve the issue of being locked out due to too many failed login attempts, restart Tomcat.

Restarting the Tomcat server can reset the failed login attempts count, allowing immediate access. 


2- To prevent this issue from occurring in the future, configure the system to allow a greater number of failed login attempts or disable this feature entirely. You can modify the behavior using the following parameters:

  •  Disable the max login attempts feature by setting (Version 2024.1.2+):
-Dxdm.idm.maxloginattempts.enable=false
  • Or, customize the maximum number of failed attempts by setting:
-Dxdm.idm.maxloginattempts=_integer_

The maximum value is 2147483647.


By configuring the appropriate parameters, you can manage how many failed login attempts are permissible and avoid being locked out in the future. Restarting Tomcat, meanwhile, offers an immediate resolution to the lockout.